What’s Vulnerable › Vulnerabilities

CVE-2022-42116

Description

A Cross-site scripting (XSS) vulnerability in the Frontend Editor module's integration with CKEditor in Liferay Portal 7.3.2 through 7.4.3.14, and Liferay DXP 7.3 before update 6, and 7.4 before update 15 allows remote attackers to inject arbitrary web script or HTML via the (1) name, or (2) namespace parameter.

Affected products

How to fix

Upgrade to a fixed version: Liferay DXP 7.3; Liferay Portal 7.4.3.15. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-42116 or the next vulnerability affects your stack