What’s Vulnerable › Vulnerabilities
CVE-2022-4223
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 80.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-13 · updated 2026-06-17
- Weakness: CWE-94
Description
The pgAdmin server includes an HTTP API that is intended to be used to validate the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. The utility is executed by the server to determine what PostgreSQL version it is from. Versions of pgAdmin prior to 6.17 failed to properly secure this API, which could allow an unauthenticated user to call it with a path of their choosing, such as a UNC path to a server they control on a Windows machine. This would cause an appropriately named executable in the target path to be executed by the pgAdmin server.
Affected products
- Fedoraproject Fedora: 37
- pgadmin.org pgAdmin 4: before 6.17 — fixed in 6.17
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 6.17. Check the vendor advisory for mitigations.
References
- https://github.com/pgadmin-org/pgadmin4/issues/5593
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/R5EYTPKHVFSDCETBJI7LBZE4EYHBPN2Q/
- https://github.com/pgadmin-org/pgadmin4/issues/5593
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/R5EYTPKHVFSDCETBJI7LBZE4EYHBPN2Q/
Get alerted when CVE-2022-4223 or the next vulnerability affects your stack