What’s Vulnerable › Vulnerabilities
CVE-2022-4224: CODESYS: Exposure of Resource to Wrong Sphere in CODESYS V3
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-23 · updated 2026-06-17
- Weakness: CWE-1188
Description
In multiple products of CODESYS v3 in multiple versions a remote low privileged user could utilize this vulnerability to read and modify system files and OS resources or DoS the device.
Affected products
- CODESYS Control for BeagleBone SL: from 3.0 before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control For Empc-A/Imx6 Sl: from 3.0 before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for IOT2000 SL: from 3.0 before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for Linux SL: from 3.0 before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for PFC100 SL: from 3.0 before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for PFC200 SL: from 3.0 before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for PLCnext SL: from 3.0 before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for Raspberry Pi SL: from 3.0 before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control for WAGO Touch Panels 600 SL: from 3.0 before 4.8.0.0 — fixed in 4.8.0.0
- CODESYS Control RTE (SL): from 3.0 before 3.5.19.0 — fixed in 3.5.19.0
- CODESYS Control Rte Sl (For Beckhoff Cx): from 3.0 before 3.5.19.0 — fixed in 3.5.19.0
- CODESYS Control Win (SL): from 3.0 before 3.5.19.0 — fixed in 3.5.19.0
- CODESYS Development System: from 3.0 before 3.5.19.0 — fixed in 3.5.19.0
- CODESYS HMI (SL): from 3.0 before 3.5.19.0 — fixed in 3.5.19.0
- CODESYS Runtime Toolkit: from 3.0 before 3.5.19.0 — fixed in 3.5.19.0
- CODESYS Safety SIL2: from 3.0 before 3.5.19.0 — fixed in 3.5.19.0
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone SL 4.8.0.0; CODESYS Control For Empc-A/Imx6 Sl 4.8.0.0; CODESYS Control for IOT2000 SL 4.8.0.0; CODESYS Control for Linux SL 4.8.0.0; CODESYS Control for PFC100 SL 4.8.0.0; CODESYS Control for PFC200 SL 4.8.0.0; CODESYS Control for PLCnext SL 4.8.0.0; CODESYS Control for Raspberry Pi SL 4.8.0.0; CODESYS Control for WAGO Touch Panels 600 SL 4.8.0.0; CODESYS Control RTE (SL) 3.5.19.0; CODESYS Control Rte Sl (For Beckhoff Cx) 3.5.19.0; CODESYS Control Win (SL) 3.5.19.0. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17553&token=cf49757d232ea8021f0c0dd6c65e71ea5942b12d&download=
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=17553&token=cf49757d232ea8021f0c0dd6c65e71ea5942b12d&download=
Get alerted when CVE-2022-4224 or the next vulnerability affects your stack