What’s Vulnerable › Vulnerabilities
CVE-2022-4227: Booster for WooCommerce - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-26 · updated 2026-06-17
Description
The Booster for WooCommerce WordPress plugin before 5.6.3, Booster Plus for WooCommerce WordPress plugin before 6.0.0, Booster Elite for WooCommerce WordPress plugin before 6.0.0 do not escape some URLs and parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting
Affected products
- Booster Elite For Woocommerce: before 6.0.0 — fixed in 6.0.0
- pluggabl Booster for WooCommerce – PDF Invoices, Abandoned Cart, Variation Swatches & 100+ Tools: before 5.6.3 — fixed in 5.6.3
- Booster Plus For Woocommerce: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: Booster Elite For Woocommerce 6.0.0; pluggabl Booster for WooCommerce – PDF Invoices, Abandoned Cart, Variation Swatches & 100+ Tools 5.6.3; Booster Plus For Woocommerce 6.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/90d3022c-5d35-4ef2-ab87-6919268db890
- https://wpscan.com/vulnerability/90d3022c-5d35-4ef2-ab87-6919268db890
Get alerted when CVE-2022-4227 or the next vulnerability affects your stack