What’s Vulnerable › Vulnerabilities
CVE-2022-4236: Welcart e-Commerce < 2.8.5 - Subscriber+ Arbitrary File Access
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-02 · updated 2026-06-17
- Weakness: CWE-552
Description
The Welcart e-Commerce WordPress plugin before 2.8.5 does not validate user input before using it to output the content of a file via an AJAX action available to any authenticated users, which could allow users with a role as low as subscriber to read arbitrary files on the server.
Affected products
- Welcart e-Commerce: before 2.8.5 — fixed in 2.8.5
How to fix
Upgrade to a fixed version: Welcart e-Commerce 2.8.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/436d8894-dab8-41ea-8ed0-a3338aded635
- https://wpscan.com/vulnerability/436d8894-dab8-41ea-8ed0-a3338aded635
Get alerted when CVE-2022-4236 or the next vulnerability affects your stack