What’s Vulnerable › Vulnerabilities
CVE-2022-42377
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-119
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of PDF-XChange Editor. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of U3D files. The issue results from the lack of proper validation of user-supplied data, which can result in a memory corruption condition. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-18630.
Affected products
- PDF-XChange Editor: before 9.5.366.0 — fixed in 9.5.366.0
How to fix
Upgrade to a fixed version: PDF-XChange Editor 9.5.366.0. Check the vendor advisory for mitigations.
References
- https://www.tracker-software.com/product/pdf-xchange-editor/history
- https://www.zerodayinitiative.com/advisories/ZDI-22-1367/
- https://www.tracker-software.com/product/pdf-xchange-editor/history
- https://www.zerodayinitiative.com/advisories/ZDI-22-1367/
Get alerted when CVE-2022-42377 or the next vulnerability affects your stack