What’s Vulnerable › Vulnerabilities
CVE-2022-42428
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-89
Description
This vulnerability allows remote attackers to escalate privileges on affected installations of Centreon. Authentication is required to exploit this vulnerability. The specific flaw exists within the handling of requests to modify poller broker configuration. The issue results from the lack of proper validation of a user-supplied string before using it to construct SQL queries. An attacker can leverage this vulnerability to escalate privileges to the level of an administrator. Was ZDI-CAN-18410.
Affected products
- centreon: before 21.04.19; from 21.10.0 before 21.10.11; from 22.04.0 before 22.04.6 — fixed in 21.04.19, 21.10.11, 22.04.6
How to fix
Upgrade to a fixed version: centreon 21.04.19, 21.10.11, 22.04.6. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-22-1399/
- https://www.zerodayinitiative.com/advisories/ZDI-22-1399/
Get alerted when CVE-2022-42428 or the next vulnerability affects your stack