What’s Vulnerable › Vulnerabilities
CVE-2022-42475: Fortinet FortiOS Heap-Based Buffer Overflow Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-12-13
- EPSS: 99.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-02 · updated 2026-06-17
- Weakness: CWE-197
Description
A heap-based buffer overflow vulnerability [CWE-122] in FortiOS SSL-VPN 7.2.0 through 7.2.2, 7.0.0 through 7.0.8, 6.4.0 through 6.4.10, 6.2.0 through 6.2.11, 6.0.15 and earlier and FortiProxy SSL-VPN 7.2.0 through 7.2.1, 7.0.7 and earlier may allow a remote unauthenticated attacker to execute arbitrary code or commands via specifically crafted requests.
Affected products
- Fortinet FortiOS (FortiGate): from 5.0.0 through 5.0.14; from 5.2.0 through 5.2.15; from 5.4.0 through 5.4.13; from 5.6.0 through 5.6.14; from 6.0.0 before 6.0.16; from 6.2.0 before 6.2.12 — fixed in 6.0.15, 6.0.16, 6.2.12, 6.4.10, 6.4.11, 7.0.8
- Fortinet FortiProxy: from 1.0.0 through 1.0.7; from 1.1.0 through 1.1.6; from 1.2.0 through 1.2.13; from 2.0.0 before 2.0.12; from 7.0.0 before 7.0.8; from 7.2.0 before 7.2.2 — fixed in 2.0.12, 7.0.8, 7.2.2
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 6.0.15, 6.0.16, 6.2.12, 6.4.10; Fortinet FortiProxy 2.0.12, 7.0.8, 7.2.2. Check the vendor advisory for mitigations.
References
- https://fortiguard.com/psirt/FG-IR-22-398
- https://fortiguard.com/psirt/FG-IR-22-398
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2022-42475
Get alerted when CVE-2022-42475 or the next vulnerability affects your stack