What’s Vulnerable › Vulnerabilities
CVE-2022-42477
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-11 · updated 2026-06-17
- Weakness: CWE-20
Description
An improper input validation vulnerability [CWE-20] in FortiAnalyzer version 7.2.1 and below, version 7.0.6 and below, 6.4 all versions may allow an authenticated attacker to disclose file system information via custom dataset SQL queries.
Affected products
- Fortinet FortiAnalyzer: from 6.4.0 before 7.0.7; 7.2.0 — fixed in 7.0.7
How to fix
Upgrade to a fixed version: Fortinet FortiAnalyzer 7.0.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-42477 or the next vulnerability affects your stack