What’s Vulnerable › Vulnerabilities
CVE-2022-4254
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-01 · updated 2026-06-17
- Weakness: CWE-90
Description
sssd: libsss_certmap fails to sanitise certificate data used in LDAP filters
Affected products
- [UNKNOWN] sssd: from 1.15.3 before 2.3.1 — fixed in 2.3.1
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux For Ibm Z Systems: 7.0
- RedHat Enterprise Linux For Power Big Endian: 7.0
- RedHat Enterprise Linux For Power Little Endian: 7.0
- RedHat Enterprise Linux For Scientific Computing: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 8.2
- RedHat Enterprise Linux Server For Power Little Endian Update Services For Sap Solutions: 8.1, 8.2
- RedHat Enterprise Linux Server Tus: 8.2
- RedHat Enterprise Linux Server Update Services For Sap Solutions: 8.1
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: [UNKNOWN] sssd 2.3.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2022-4254
- https://bugzilla.redhat.com/show_bug.cgi?id=2149894
- https://github.com/SSSD/sssd/commit/a2b9a84460429181f2a4fa7e2bb5ab49fd561274
- https://github.com/SSSD/sssd/issues/5135
- https://lists.debian.org/debian-lts-announce/2023/05/msg00028.html
- https://access.redhat.com/security/cve/CVE-2022-4254
- https://bugzilla.redhat.com/show_bug.cgi?id=2149894
- https://github.com/SSSD/sssd/commit/a2b9a84460429181f2a4fa7e2bb5ab49fd561274
- https://github.com/SSSD/sssd/issues/5135
- https://lists.debian.org/debian-lts-announce/2023/05/msg00028.html
Get alerted when CVE-2022-4254 or the next vulnerability affects your stack