What’s Vulnerable › Vulnerabilities
CVE-2022-4256: All-in-One Addons for Elementor - WidgetKit < 2.4.4 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-02 · updated 2026-06-17
Description
The All-in-One Addons for Elementor WordPress plugin before 2.4.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- shamsbd71 All-in-One Addons for Elementor – WidgetKit: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: shamsbd71 All-in-One Addons for Elementor – WidgetKit 2.4.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f5b17c68-c2b0-4d0d-bb7b-19dc30511a89
- https://wpscan.com/vulnerability/f5b17c68-c2b0-4d0d-bb7b-19dc30511a89
Get alerted when CVE-2022-4256 or the next vulnerability affects your stack