What’s Vulnerable › Vulnerabilities
CVE-2022-4260: WP-Ban < 1.69.1 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-02 · updated 2026-06-17
Description
The WP-Ban WordPress plugin before 1.69.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- WP-Ban: before 1.69.1 — fixed in 1.69.1
How to fix
Upgrade to a fixed version: WP-Ban 1.69.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d0cf24be-df87-4e1f-aae7-e9684c88e7db
- https://wpscan.com/vulnerability/d0cf24be-df87-4e1f-aae7-e9684c88e7db
Get alerted when CVE-2022-4260 or the next vulnerability affects your stack