What’s Vulnerable › Vulnerabilities
CVE-2022-4261: Rapid7 Nexpose Update Validation Issue
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-08 · updated 2026-06-17
- Weakness: CWE-494
Description
Rapid7 Nexpose and InsightVM versions prior to 6.6.172 failed to reliably validate the authenticity of update contents. This failure could allow an attacker to provide a malicious update and alter the functionality of Rapid7 Nexpose. The attacker would need some pre-existing mechanism to provide a malicious update, either through a social engineering effort, privileged access to replace downloaded updates in transit, or by performing an Attacker-in-the-Middle attack on the update service itself.
Affected products
- Rapid7 InsightVM: before 6.6.172 — fixed in 6.6.172
- Rapid7 Nexpose: before 6.6.172 — fixed in 6.6.172
How to fix
Upgrade to a fixed version: Rapid7 InsightVM 6.6.172; Rapid7 Nexpose 6.6.172. Check the vendor advisory for mitigations.
References
- https://docs.rapid7.com/release-notes/insightvm/20221207/
- https://docs.rapid7.com/release-notes/nexpose/20221207/
- https://www.rapid7.com/blog/post/2022/12/7/cve-2022-4261-rapid7-nexpose-update-validation-issue-fixed
- https://docs.rapid7.com/release-notes/insightvm/20221207/
- https://docs.rapid7.com/release-notes/nexpose/20221207/
- https://www.rapid7.com/blog/post/2022/12/7/cve-2022-4261-rapid7-nexpose-update-validation-issue-fixed
Get alerted when CVE-2022-4261 or the next vulnerability affects your stack