What’s Vulnerable › Vulnerabilities
CVE-2022-42705
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-05 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free in res_pjsip_pubsub.c in Sangoma Asterisk 16.28, 18.14, 19.6, and certified/18.9-cert2 may allow a remote authenticated attacker to crash Asterisk (denial of service) by performing activity on a subscription via a reliable transport at the same time that Asterisk is also performing activity on that subscription.
Affected products
- asterisk: from 16.0.0 before 16.29.1; from 18.14.0 before 18.15.1; from 19.6.0 before 19.7.1; 20.0.0 — fixed in 16.29.1, 18.15.1, 19.7.1
- Sangoma Certified Asterisk: 18.9-cert2
How to fix
Upgrade to a fixed version: asterisk 16.29.1, 18.15.1, 19.7.1. Check the vendor advisory for mitigations.
References
- https://downloads.asterisk.org/pub/security/AST-2022-008.html
- https://lists.debian.org/debian-lts-announce/2023/02/msg00029.html
- https://www.debian.org/security/2023/dsa-5358
- https://downloads.asterisk.org/pub/security/AST-2022-008.html
- https://lists.debian.org/debian-lts-announce/2023/02/msg00029.html
- https://www.debian.org/security/2023/dsa-5358
Get alerted when CVE-2022-42705 or the next vulnerability affects your stack