What’s Vulnerable › Vulnerabilities
CVE-2022-42706
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-05 · updated 2026-06-17
- Weakness: CWE-22
Description
An issue was discovered in Sangoma Asterisk through 16.28, 17 and 18 through 18.14, 19 through 19.6, and certified through 18.9-cert1. GetConfig, via Asterisk Manager Interface, allows a connected application to access files outside of the asterisk configuration directory, aka Directory Traversal.
Affected products
- asterisk: from 16.0.0 before 16.29.1; from 17.0.0 before 18.15.1; from 19.0.0 before 19.7.1; 20.0.0 — fixed in 16.29.1, 18.15.1, 19.7.1
- Sangoma Certified Asterisk: before 18.9; 18.9-cert1 — fixed in 18.9
How to fix
Upgrade to a fixed version: asterisk 16.29.1, 18.15.1, 19.7.1; Sangoma Certified Asterisk 18.9. Check the vendor advisory for mitigations.
References
- https://downloads.asterisk.org/pub/security/AST-2022-009.html
- https://lists.debian.org/debian-lts-announce/2023/02/msg00029.html
- https://www.debian.org/security/2023/dsa-5358
- https://downloads.asterisk.org/pub/security/AST-2022-009.html
- https://lists.debian.org/debian-lts-announce/2023/02/msg00029.html
- https://www.debian.org/security/2023/dsa-5358
Get alerted when CVE-2022-42706 or the next vulnerability affects your stack