What’s Vulnerable › Vulnerabilities
CVE-2022-4271: Cross-site Scripting (XSS) - Reflected in osticket/osticket
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository osticket/osticket prior to 1.16.4.
Affected products
- osticket/osticket: before 1.16.4 — fixed in 1.16.4
How to fix
Upgrade to a fixed version: osticket/osticket 1.16.4. Check the vendor advisory for mitigations.
References
- https://github.com/osticket/osticket/commit/5213ff138c6be6144a6692376ac0803a42eca168
- https://huntr.dev/bounties/a11c922f-255a-412a-aa87-7f3bd7121599
- https://github.com/osticket/osticket/commit/5213ff138c6be6144a6692376ac0803a42eca168
- https://huntr.dev/bounties/a11c922f-255a-412a-aa87-7f3bd7121599
Get alerted when CVE-2022-4271 or the next vulnerability affects your stack