What’s Vulnerable › Vulnerabilities
CVE-2022-42718
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-01 · updated 2026-06-17
- Weakness: CWE-276
Description
Incorrect default permissions in the installation folder for NI LabVIEW Command Line Interface (CLI) may allow an authenticated user to potentially enable escalation of privilege via local access.
Affected products
- NI Labview Command Line Interface: before 22.3.1 — fixed in 22.3.1
How to fix
Upgrade to a fixed version: NI Labview Command Line Interface 22.3.1. Check the vendor advisory for mitigations.
References
- https://www.ni.com/en-us/support/documentation/supplemental/22/privilege-escalation-in-ni-labview-cli-.html
- https://www.ni.com/en-us/support/documentation/supplemental/22/privilege-escalation-in-ni-labview-cli-.html
Get alerted when CVE-2022-42718 or the next vulnerability affects your stack