What’s Vulnerable › Vulnerabilities

CVE-2022-42719

Description

A use-after-free in the mac80211 stack when parsing a multi-BSSID element in the Linux kernel 5.2 through 5.19.x before 5.19.16 could be used by attackers (able to inject WLAN frames) to crash the kernel and potentially execute code.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 5.10.149, 5.15.74, 5.19.16, 5.4.219. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-42719 or the next vulnerability affects your stack