What’s Vulnerable › Vulnerabilities

CVE-2022-42721

Description

A list management bug in BSS handling in the mac80211 stack in the Linux kernel 5.1 through 5.19.x before 5.19.16 could be used by local attackers (able to inject WLAN frames) to corrupt a linked list and, in turn, potentially execute code.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 5.19.16. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-42721 or the next vulnerability affects your stack