What’s Vulnerable › Vulnerabilities
CVE-2022-42858
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-10 · updated 2026-06-17
- Weakness: CWE-787
Description
A memory corruption issue was addressed with improved input validation. This issue is fixed in macOS Ventura 13.1. An app may be able to execute arbitrary code with kernel privileges
Affected products
- Apple macOS: before 13.1 — fixed in 13.1
How to fix
Upgrade to a fixed version: Apple macOS 13.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-42858 or the next vulnerability affects your stack