What’s Vulnerable › Vulnerabilities
CVE-2022-42889: Apache Commons Text prior to 1.10.0 allows RCE when applied to untrusted input due to insecure interpolation defaults
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 99.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-13 · updated 2026-06-17
- Weakness: CWE-94
Description
Apache Commons Text performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.text.lookup.StringLookup that performs the interpolation. Starting with version 1.5 and continuing through 1.9, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Text 1.10.0, which disables the problematic interpolators by default.
Affected products
- Apache Commons Text: from 1.5 before 1.10.0 — fixed in 1.10.0
- Juniper Security Threat Response Manager: before 7.5.0; 7.5.0, 7.5.0-up1, 7.5.0-up2, 7.5.0-up3 — fixed in 7.5.0
- NetApp Bluexp: all versions
- Maven Com.Guicedee.Services:Commons-Text: through 1.2.2.1-jre17; 0.70.0.1, 0.70.0.1-rc1, 0.70.0.1-rc13, 0.70.0.1-rc14, 0.70.0.1-rc15, 0.70.0.1-rc2 (+439)
- Maven Org.Apache.Commons:Commons-Text: from 1.5 before 1.10.0; 1.5, 1.6, 1.7, 1.8, 1.9 — fixed in 1.10.0
How to fix
Upgrade to a fixed version: Apache Commons Text 1.10.0; Juniper Security Threat Response Manager 7.5.0; Maven Org.Apache.Commons:Commons-Text 1.10.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/171003/OX-App-Suite-Cross-Site-Scripting-Server-Side-Request-Forgery.html
- http://packetstormsecurity.com/files/176650/Apache-Commons-Text-1.9-Remote-Code-Execution.html
- http://seclists.org/fulldisclosure/2023/Feb/3
- http://www.openwall.com/lists/oss-security/2022/10/13/4
- http://www.openwall.com/lists/oss-security/2022/10/18/1
- https://lists.apache.org/thread/n2bd4vdsgkqh2tm14l1wyc3jyol7s1om
- https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2022-0022
- https://security.gentoo.org/glsa/202301-05
- https://security.netapp.com/advisory/ntap-20221020-0004/
- http://packetstormsecurity.com/files/171003/OX-App-Suite-Cross-Site-Scripting-Server-Side-Request-Forgery.html
- http://packetstormsecurity.com/files/176650/Apache-Commons-Text-1.9-Remote-Code-Execution.html
- http://seclists.org/fulldisclosure/2023/Feb/3
Get alerted when CVE-2022-42889 or the next vulnerability affects your stack