What’s Vulnerable › Vulnerabilities

CVE-2022-4289

Description

An issue has been discovered in GitLab affecting all versions starting from 15.3 before 15.7.8, versions of 15.8 before 15.8.4, and version 15.9 before 15.9.2. Google IAP details in Prometheus integration were not hidden, could be leaked from instance, group, or project settings to other users.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.7.8, 15.8.4, 15.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-4289 or the next vulnerability affects your stack