What’s Vulnerable › Vulnerabilities
CVE-2022-42890: Apache Batik prior to 1.16 allows RCE via scripting
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-25 · updated 2026-06-17
- Weakness: CWE-918
Description
A vulnerability in Batik of Apache XML Graphics allows an attacker to run Java code from untrusted SVG via JavaScript. This issue affects Apache XML Graphics prior to 1.16. Users are recommended to upgrade to version 1.16.
Affected products
- Apache Software Foundation Apache Batik: from 1.0 before 1.16 — fixed in 1.16
- Debian Linux: 10.0, 11.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Batik 1.16. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/10/25/3
- https://lists.apache.org/thread/pkvhy0nsj1h1mlon008wtzhosbtxjwly
- https://lists.debian.org/debian-lts-announce/2022/10/msg00038.html
- https://security.gentoo.org/glsa/202401-11
- https://www.debian.org/security/2022/dsa-5264
- http://www.openwall.com/lists/oss-security/2022/10/25/3
- https://lists.apache.org/thread/pkvhy0nsj1h1mlon008wtzhosbtxjwly
- https://lists.debian.org/debian-lts-announce/2022/10/msg00038.html
- https://security.gentoo.org/glsa/202401-11
- https://www.debian.org/security/2022/dsa-5264
Get alerted when CVE-2022-42890 or the next vulnerability affects your stack