What’s Vulnerable › Vulnerabilities

CVE-2022-42898

Description

PAC parsing in MIT Kerberos 5 (aka krb5) before 1.19.4 and 1.20.x before 1.20.1 has integer overflows that may lead to remote code execution (in KDC, kadmind, or a GSS or Kerberos application server) on 32-bit platforms (which have a resultant heap-based buffer overflow), and cause a denial of service on other platforms. This occurs in krb5_pac_parse in lib/krb5/krb/pac.c. Heimdal before 7.7.1 has "a similar bug."

Affected products

How to fix

Upgrade to a fixed version: Heimdal Software Kerberos 7.7.1; MIT Kerberos 5 1.19.4; Samba 4.15.12, 4.16.7, 4.17.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-42898 or the next vulnerability affects your stack