What’s Vulnerable › Vulnerabilities
CVE-2022-42899
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-13 · updated 2026-06-17
- Weakness: CWE-125
Description
Bentley MicroStation and MicroStation-based applications may be affected by out-of-bounds read and stack overflow issues when opening crafted SKP files. Exploiting these issues could lead to information disclosure and code execution. The fixed versions are 10.17.01.58* for MicroStation and 10.17.01.19* for Bentley View.
Affected products
- Bentley MicroStation: before 10.17.01.58 — fixed in 10.17.01.58
- Bentley View: before 10.17.01.19 — fixed in 10.17.01.19
How to fix
Upgrade to a fixed version: Bentley MicroStation 10.17.01.58; Bentley View 10.17.01.19. Check the vendor advisory for mitigations.
References
- https://www.bentley.com/legal/common-vulnerability-exposure-be-2022-0017/
- https://www.bentley.com/legal/common-vulnerability-exposure-be-2022-0017/
Get alerted when CVE-2022-42899 or the next vulnerability affects your stack