What’s Vulnerable › Vulnerabilities

CVE-2022-4290: Cyr to Lat <= 3.5 - Authenticated SQL Injection

Description

The Cyr to Lat plugin for WordPress is vulnerable to authenticated SQL Injection via the 'ctl_sanitize_title' function in versions up to, and including, 3.5 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This potentially allows authenticated users with the ability to add or modify terms or tags to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. A partial patch became available in version 3.6 and the issue was fully patched in version 3.7.

Affected products

How to fix

Upgrade to a fixed version: ivijanstefan Cyr to Lat Enhanced 3.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-4290 or the next vulnerability affects your stack