What’s Vulnerable › Vulnerabilities
CVE-2022-42902
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-13 · updated 2026-06-17
- Weakness: CWE-94
Description
In Linaro Automated Validation Architecture (LAVA) before 2022.10, there is dynamic code execution in lava_server/lavatable.py. Due to improper input sanitization, an anonymous user can force the lava-server-gunicorn service to execute user-provided code on the server.
Affected products
- Debian Linux: 10.0, 11.0
- Linaro Lava: before 2022.10 — fixed in 2022.10
How to fix
Upgrade to a fixed version: Linaro Lava 2022.10. Check the vendor advisory for mitigations.
References
- https://git.lavasoftware.org/lava/lava/-/commit/e66b74cd6c175ff8826b8f3431740963be228b52?merge_request_iid=1834
- https://git.lavasoftware.org/lava/lava/-/merge_requests/1834
- https://lists.debian.org/debian-lts-announce/2022/11/msg00019.html
- https://www.debian.org/security/2022/dsa-5260
- https://git.lavasoftware.org/lava/lava/-/commit/e66b74cd6c175ff8826b8f3431740963be228b52?merge_request_iid=1834
- https://git.lavasoftware.org/lava/lava/-/merge_requests/1834
- https://lists.debian.org/debian-lts-announce/2022/11/msg00019.html
- https://www.debian.org/security/2022/dsa-5260
Get alerted when CVE-2022-42902 or the next vulnerability affects your stack