What’s Vulnerable › Vulnerabilities
CVE-2022-42906
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-13 · updated 2026-06-17
- Weakness: CWE-77
Description
powerline-gitstatus (aka Powerline Gitstatus) before 1.3.2 allows arbitrary code execution. git repositories can contain per-repository configuration that changes the behavior of git, including running arbitrary commands. When using powerline-gitstatus, changing to a directory automatically runs git commands in order to display information about the current repository in the prompt. If an attacker can convince a user to change their current directory to one controlled by the attacker, such as in a shared filesystem or extracted archive, powerline-gitstatus will run arbitrary commands under the attacker's control. NOTE: this is similar to CVE-2022-20001.
Affected products
- Debian Linux: 10.0
- Powerline Gitstatus Project Powerline Gitstatus: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: Powerline Gitstatus Project Powerline Gitstatus 1.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/jaspernbrouwer/powerline-gitstatus/issues/45
- https://github.com/jaspernbrouwer/powerline-gitstatus/releases/tag/v1.3.2
- https://lists.debian.org/debian-lts-announce/2023/01/msg00017.html
- https://github.com/jaspernbrouwer/powerline-gitstatus/issues/45
- https://github.com/jaspernbrouwer/powerline-gitstatus/releases/tag/v1.3.2
- https://lists.debian.org/debian-lts-announce/2023/01/msg00017.html
Get alerted when CVE-2022-42906 or the next vulnerability affects your stack