What’s Vulnerable › Vulnerabilities
CVE-2022-4292: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-05 · updated 2026-06-17
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 9.0.0882.
Affected products
- NetApp ONTAP Select Deploy administration utility: all versions
- vim/vim: before 9.0.0882 — fixed in 9.0.0882
How to fix
Upgrade to a fixed version: vim/vim 9.0.0882. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/c3d27ada14acd02db357f2d16347acc22cb17e93
- https://huntr.dev/bounties/da3d4c47-e57a-451e-993d-9df0ed31f57b
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WYC22GGZ6QA66HLNLHCTAJU265TT3O33/
- https://security.gentoo.org/glsa/202305-16
- https://security.netapp.com/advisory/ntap-20230113-0005/
- https://github.com/vim/vim/commit/c3d27ada14acd02db357f2d16347acc22cb17e93
- https://huntr.dev/bounties/da3d4c47-e57a-451e-993d-9df0ed31f57b
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WYC22GGZ6QA66HLNLHCTAJU265TT3O33/
- https://security.gentoo.org/glsa/202305-16
- https://security.netapp.com/advisory/ntap-20230113-0005/
Get alerted when CVE-2022-4292 or the next vulnerability affects your stack