What’s Vulnerable › Vulnerabilities
CVE-2022-42929
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-400
Description
If a website called `window.print()` in a particular way, it could cause a denial of service of the browser, which may persist beyond browser restart depending on the user's session restore settings. This vulnerability affects Firefox < 106, Firefox ESR < 102.4, and Thunderbird < 102.4.
Affected products
- Mozilla Firefox: before 106.0 — fixed in 106.0
- Mozilla Firefox ESR: before 102.4 — fixed in 102.4
- Mozilla Thunderbird: before 102.4 — fixed in 102.4
How to fix
Upgrade to a fixed version: Mozilla Firefox 106.0; Mozilla Firefox ESR 102.4; Mozilla Thunderbird 102.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1789439
- https://www.mozilla.org/security/advisories/mfsa2022-44/
- https://www.mozilla.org/security/advisories/mfsa2022-45/
- https://www.mozilla.org/security/advisories/mfsa2022-46/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1789439
- https://www.mozilla.org/security/advisories/mfsa2022-44/
- https://www.mozilla.org/security/advisories/mfsa2022-45/
- https://www.mozilla.org/security/advisories/mfsa2022-46/
Get alerted when CVE-2022-42929 or the next vulnerability affects your stack