What’s Vulnerable › Vulnerabilities
CVE-2022-4293: Floating Point Comparison with Incorrect Operator in vim/vim
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-05 · updated 2026-06-17
- Weakness: CWE-1077
Description
Floating Point Comparison with Incorrect Operator in GitHub repository vim/vim prior to 9.0.0804.
Affected products
- vim/vim: before 9.0.0804 — fixed in 9.0.0804
How to fix
Upgrade to a fixed version: vim/vim 9.0.0804. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/cdef1cefa2a440911c727558562f83ed9b00e16b
- https://huntr.dev/bounties/385a835f-6e33-4d00-acce-ac99f3939143
- https://security.gentoo.org/glsa/202305-16
- https://security.netapp.com/advisory/ntap-20230203-0007/
- https://github.com/vim/vim/commit/cdef1cefa2a440911c727558562f83ed9b00e16b
- https://huntr.dev/bounties/385a835f-6e33-4d00-acce-ac99f3939143
- https://security.gentoo.org/glsa/202305-16
- https://security.netapp.com/advisory/ntap-20230203-0007/
Get alerted when CVE-2022-4293 or the next vulnerability affects your stack