What’s Vulnerable › Vulnerabilities
CVE-2022-4295: Show All Comments < 7.0.1 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The Show All Comments WordPress plugin before 7.0.1 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against a logged in high privilege users such as admin.
Affected products
- Show All Comments: before 7.0.1 — fixed in 7.0.1
How to fix
Upgrade to a fixed version: Show All Comments 7.0.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4ced1a4d-0c1f-42ad-8473-241c68b92b56
- https://wpscan.com/vulnerability/4ced1a4d-0c1f-42ad-8473-241c68b92b56
Get alerted when CVE-2022-4295 or the next vulnerability affects your stack