What’s Vulnerable › Vulnerabilities
CVE-2022-42961
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-15 · updated 2026-06-17
- Weakness: CWE-285
Description
An issue was discovered in wolfSSL before 5.5.0. A fault injection attack on RAM via Rowhammer leads to ECDSA key disclosure. Users performing signing operations with private ECC keys, such as in server-side TLS connections, might leak faulty ECC signatures. These signatures can be processed via an advanced technique for ECDSA key recovery. (In 5.5.0 and later, WOLFSSL_CHECK_SIG_FAULTS can be used to address the vulnerability.)
Affected products
- wolfSSL: before 5.5.0 — fixed in 5.5.0
How to fix
Upgrade to a fixed version: wolfSSL 5.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/wolfSSL/wolfssl/releases/tag/v5.5.0-stable
- https://github.com/wolfSSL/wolfssl/releases/tag/v5.5.0-stable
Get alerted when CVE-2022-42961 or the next vulnerability affects your stack