What’s Vulnerable › Vulnerabilities
CVE-2022-4299: Metricool < 1.18 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The Metricool WordPress plugin before 1.18 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Metricool: before 1.18 — fixed in 1.18
How to fix
Upgrade to a fixed version: Metricool 1.18. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/169c5611-ed10-4cc3-bd07-09b365adf303
- https://wpscan.com/vulnerability/169c5611-ed10-4cc3-bd07-09b365adf303
Get alerted when CVE-2022-4299 or the next vulnerability affects your stack