What’s Vulnerable › Vulnerabilities
CVE-2022-4320: WordPress Events Calendar Plugin < 1.4.5 - Multiple Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The WordPress Events Calendar WordPress plugin before 1.4.5 does not sanitize and escapes a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against both unauthenticated and authenticated users (such as high-privilege ones like admin).
Affected products
- WordPress Events Calendar Plugin: before 1.4.5 — fixed in 1.4.5
How to fix
Upgrade to a fixed version: WordPress Events Calendar Plugin 1.4.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f1244c57-d886-4a6e-8cdb-18404e8c153c
- https://wpscan.com/vulnerability/f1244c57-d886-4a6e-8cdb-18404e8c153c
Get alerted when CVE-2022-4320 or the next vulnerability affects your stack