What’s Vulnerable › Vulnerabilities
CVE-2022-4321: PDF Generator for WordPress < 1.1.2 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The PDF Generator for WordPress plugin before 1.1.2 includes a vendored dompdf example file which is susceptible to Reflected Cross-Site Scripting and could be used against high privilege users such as admin
Affected products
- WP Swings PDF Generator for WordPress: before 1.1.2 — fixed in 1.1.2
How to fix
Upgrade to a fixed version: WP Swings PDF Generator for WordPress 1.1.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6ac1259c-86d9-428b-ba98-7f3d07910644
- https://wpscan.com/vulnerability/6ac1259c-86d9-428b-ba98-7f3d07910644
Get alerted when CVE-2022-4321 or the next vulnerability affects your stack