What’s Vulnerable › Vulnerabilities
CVE-2022-4324: Custom Field Template < 2.5.8 - Admin+ PHP Object Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-02 · updated 2026-06-17
Description
The Custom Field Template WordPress plugin before 2.5.8 unserialises the content of an imported file, which could lead to PHP object injections issues when a high privilege user import (intentionally or not) a malicious Customizer Styling file and a suitable gadget chain is present on the blog.
Affected products
- hiroaki-miyashita Custom Field Template: before 2.5.8 — fixed in 2.5.8
How to fix
Upgrade to a fixed version: hiroaki-miyashita Custom Field Template 2.5.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/70c39236-f7ae-49bf-a2f0-7cb9aa983e45
- https://wpscan.com/vulnerability/70c39236-f7ae-49bf-a2f0-7cb9aa983e45
Get alerted when CVE-2022-4324 or the next vulnerability affects your stack