What’s Vulnerable › Vulnerabilities
CVE-2022-4331
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-09 · updated 2026-06-17
- Weakness: CWE-284
Description
An issue has been discovered in GitLab EE affecting all versions starting from 15.1 before 15.7.8, all versions starting from 15.8 before 15.8.4, all versions starting from 15.9 before 15.9.2. If a group with SAML SSO enabled is transferred to a new namespace as a child group, it's possible previously removed malicious maintainer or owner of the child group can still gain access to the group via SSO or a SCIM token to perform actions on the group.
Affected products
- GitLab: from 15.1 before 15.7.8; from 15.8 before 15.8.4; from 15.9 before 15.9.2 — fixed in 15.7.8, 15.8.4, 15.9.2
How to fix
Upgrade to a fixed version: GitLab 15.7.8, 15.8.4, 15.9.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-4331.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/385050
- https://hackerone.com/reports/1791518
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-4331.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/385050
- https://hackerone.com/reports/1791518
Get alerted when CVE-2022-4331 or the next vulnerability affects your stack