What’s Vulnerable › Vulnerabilities
CVE-2022-4338
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-10 · updated 2026-06-17
- Weakness: CWE-125
Description
An integer underflow in Organization Specific TLV was found in various versions of OpenvSwitch.
Affected products
- Debian Linux: 11.0
- Openvswitch: before 2.13.10; from 2.14.0 before 2.14.8; from 2.15.0 before 2.15.7; from 2.16.0 before 2.16.6; from 2.17.0 before 2.17.5; from 3.0.0 before 3.0.3 — fixed in 2.13.10, 2.14.8, 2.15.7, 2.16.6, 2.17.5, 3.0.3
How to fix
Upgrade to a fixed version: Openvswitch 2.13.10, 2.14.8, 2.15.7, 2.16.6. Check the vendor advisory for mitigations.
References
- https://github.com/openvswitch/ovs/pull/405
- https://mail.openvswitch.org/pipermail/ovs-dev/2022-December/400596.html
- https://security.gentoo.org/glsa/202311-16
- https://www.debian.org/security/2023/dsa-5319
- https://www.openwall.com/lists/oss-security/2022/12/21/4
- https://github.com/openvswitch/ovs/pull/405
- https://mail.openvswitch.org/pipermail/ovs-dev/2022-December/400596.html
- https://security.gentoo.org/glsa/202311-16
- https://www.debian.org/security/2023/dsa-5319
- https://www.openwall.com/lists/oss-security/2022/12/21/4
Get alerted when CVE-2022-4338 or the next vulnerability affects your stack