What’s Vulnerable › Vulnerabilities
CVE-2022-43391
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-11 · updated 2026-06-17
- Weakness: CWE-120
Description
A buffer overflow vulnerability in the parameter of the CGI program in Zyxel NR7101 firmware prior to V1.15(ACCC.3)C0, which could allow an authenticated attacker to cause denial-of-service (DoS) conditions by sending a crafted HTTP request.
Affected products
- Zyxel AX7501-B0 firmware: all versions
- Zyxel DX3301-T0 firmware: all versions
- Zyxel Dx4510-B1 Firmware: all versions
- Zyxel DX5401-B0 firmware: all versions
- Zyxel Emg3525-T50B Firmware: all versions
- Zyxel Emg5523-T50B Firmware: all versions
- Zyxel Emg5723-T50K Firmware: all versions
- Zyxel EX3301-T0 firmware: all versions
- Zyxel EX3510-B0 firmware: before 5.17\(abup.7\)c0 — fixed in 5.17\(abup.7\)c0
- Zyxel Ex5401-B0 Firmware: all versions
- Zyxel Ex5501-B0 Firmware: all versions
- Zyxel Ex5510-B0 Firmware: before 5.17\(abqx.7\)c0 — fixed in 5.17\(abqx.7\)c0
- Zyxel Ex5512-T0 Firmware: all versions
- Zyxel Ex5600-T1 Firmware: all versions
- Zyxel Ex5601-T0 Firmware: all versions
- Zyxel EX5601-T1 firmware: all versions
- Zyxel Lte3301-Plus Firmware: all versions
- Zyxel Lte5388-M804 Firmware: all versions
- Zyxel Lte5398-M904 Firmware: all versions
- Zyxel Lte7240-M403 Firmware: all versions
- Zyxel Lte7461-M602 Firmware: all versions
- Zyxel Lte7480-M804 Firmware: before 1.00\(abra.6\)c0 — fixed in 1.00\(abra.6\)c0
- Zyxel Lte7480-S905 Firmware: all versions
- Zyxel Lte7485-S905 Firmware: all versions
- Zyxel Lte7490-M904 Firmware: before 1.00\(abqy.5\)c0 — fixed in 1.00\(abqy.5\)c0
- Zyxel Nebula Lte3301-Plus Firmware: before 1.15\(acca.3\)c0 — fixed in 1.15\(acca.3\)c0
- Zyxel Nebula Lte7461-M602 Firmware: before 1.15\(acev.3\)c0 — fixed in 1.15\(acev.3\)c0
- Zyxel Nebula Nr5101 Firmware: before 1.15\(accg.3\)c0 — fixed in 1.15\(accg.3\)c0
- Zyxel Nebula Nr7101 Firmware: before 1.15\(accc.3\)c0 — fixed in 1.15\(accc.3\)c0
- Zyxel Nr5101 Firmware: before 1.00\(abvc.6\)c0 — fixed in 1.00\(abvc.6\)c0
How to fix
Upgrade to a fixed version: Zyxel EX3510-B0 firmware 5.17\(abup.7\)c0; Zyxel Ex5510-B0 Firmware 5.17\(abqx.7\)c0; Zyxel Lte7480-M804 Firmware 1.00\(abra.6\)c0; Zyxel Lte7490-M904 Firmware 1.00\(abqy.5\)c0; Zyxel Nebula Lte3301-Plus Firmware 1.15\(acca.3\)c0; Zyxel Nebula Lte7461-M602 Firmware 1.15\(acev.3\)c0; Zyxel Nebula Nr5101 Firmware 1.15\(accg.3\)c0; Zyxel Nebula Nr7101 Firmware 1.15\(accc.3\)c0; Zyxel Nr5101 Firmware 1.00\(abvc.6\)c0; Zyxel NR7101 firmware 1.00\(abuv.7\)c0; Zyxel Nr7102 Firmware 1.00\(abyd.2\)c0. Check the vendor advisory for mitigations.
References
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-command-injection-and-buffer-overflow-vulnerabilities-of-cpe-fiber-onts-and-wifi-extenders
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-command-injection-and-buffer-overflow-vulnerabilities-of-cpe-fiber-onts-and-wifi-extenders
Get alerted when CVE-2022-43391 or the next vulnerability affects your stack