What’s Vulnerable › Vulnerabilities
CVE-2022-43396: Apache Kylin: Command injection by Useless configuration
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 55.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-30 · updated 2026-06-17
- Weakness: CWE-184
Description
In the fix for CVE-2022-24697, a blacklist is used to filter user input commands. But there is a risk of being bypassed. The user can control the command by controlling the kylin.engine.spark-cmd parameter of conf.
Affected products
- Apache Software Foundation Apache Kylin: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kylin 4.0.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/ob2ks04zl5ms0r44cd74y1xdl1rzfd1r
- https://lists.apache.org/thread/ob2ks04zl5ms0r44cd74y1xdl1rzfd1r
Get alerted when CVE-2022-43396 or the next vulnerability affects your stack