What’s Vulnerable › Vulnerabilities
CVE-2022-43413
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-19 · updated 2026-06-17
- Weakness: CWE-862
Description
Jenkins Job Import Plugin 3.5 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.
Affected products
- Jenkins project Jenkins Job Import Plugin: before 3.6 — fixed in 3.6
How to fix
Upgrade to a fixed version: Jenkins project Jenkins Job Import Plugin 3.6. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/10/19/3
- https://www.jenkins.io/security/advisory/2022-10-19/#SECURITY-2791
- http://www.openwall.com/lists/oss-security/2022/10/19/3
- https://www.jenkins.io/security/advisory/2022-10-19/#SECURITY-2791
Get alerted when CVE-2022-43413 or the next vulnerability affects your stack