What’s Vulnerable › Vulnerabilities
CVE-2022-43415
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-19 · updated 2026-06-17
- Weakness: CWE-611
Description
Jenkins REPO Plugin 1.15.0 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.
Affected products
- Jenkins project Jenkins REPO Plugin: before 1.16.0 — fixed in 1.16.0
How to fix
Upgrade to a fixed version: Jenkins project Jenkins REPO Plugin 1.16.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/10/19/3
- https://www.jenkins.io/security/advisory/2022-10-19/#SECURITY-2337
- http://www.openwall.com/lists/oss-security/2022/10/19/3
- https://www.jenkins.io/security/advisory/2022-10-19/#SECURITY-2337
Get alerted when CVE-2022-43415 or the next vulnerability affects your stack