What’s Vulnerable › Vulnerabilities
CVE-2022-43420
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Jenkins Contrast Continuous Application Security Plugin 3.9 and earlier does not escape data returned from the Contrast service when generating a report, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control or modify Contrast service API responses.
Affected products
- Jenkins Project Jenkins Contrast Continuous Application Security Plugin: before 3.10 — fixed in 3.10
How to fix
Upgrade to a fixed version: Jenkins Project Jenkins Contrast Continuous Application Security Plugin 3.10. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/10/19/3
- https://www.jenkins.io/security/advisory/2022-10-19/#SECURITY-2836
- http://www.openwall.com/lists/oss-security/2022/10/19/3
- https://www.jenkins.io/security/advisory/2022-10-19/#SECURITY-2836
Get alerted when CVE-2022-43420 or the next vulnerability affects your stack