What’s Vulnerable › Vulnerabilities
CVE-2022-4343: Exposure of Sensitive Information to an Unauthorized Actor in GitLab
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-01 · updated 2026-06-17
- Weakness: CWE-200
Description
An issue has been discovered in GitLab EE affecting all versions starting from 13.12 before 16.1.5, all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1 in which a project member can leak credentials stored in site profile.
Affected products
- GitLab: from 13.12 before 16.1.5; from 16.2 before 16.2.5; 16.3.0 — fixed in 16.1.5, 16.2.5
How to fix
Upgrade to a fixed version: GitLab 16.1.5, 16.2.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/385124
- https://hackerone.com/reports/1767797
- https://gitlab.com/gitlab-org/gitlab/-/issues/385124
- https://hackerone.com/reports/1767797
Get alerted when CVE-2022-4343 or the next vulnerability affects your stack