What’s Vulnerable › Vulnerabilities
CVE-2022-43440: Privilege escalation via manipulated unixcat executable
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-09 · updated 2026-06-17
- Weakness: CWE-427
Description
Uncontrolled Search Path Element in Checkmk Agent in Tribe29 Checkmk before 2.1.0p1, before 2.0.0p25 and before 1.6.0p29 on a Checkmk server allows the site user to escalate privileges via a manipulated unixcat executable
Affected products
- Checkmk GmbH Checkmk: before 1.6.0; 1.6.0, 1.6.0-b1, 1.6.0-b10, 1.6.0-b11, 1.6.0-b12, 1.6.0-b2 (+79) — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Checkmk GmbH Checkmk 1.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-43440 or the next vulnerability affects your stack