What’s Vulnerable › Vulnerabilities
CVE-2022-43507
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-10 · updated 2026-06-17
- Weakness: CWE-92
Description
Improper buffer restrictions in the Intel(R) QAT Engine for OpenSSL before version 0.6.16 may allow a privileged user to potentially enable escalation of privilege via network access.
Affected products
- Intel(R) QAT Engine for OpenSSL: before 0.6.16 — fixed in 0.6.16
How to fix
Upgrade to a fixed version: Intel(R) QAT Engine for OpenSSL 0.6.16. Check the vendor advisory for mitigations.
References
- https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00798.html
- https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00798.html
Get alerted when CVE-2022-43507 or the next vulnerability affects your stack