What’s Vulnerable › Vulnerabilities
CVE-2022-43548
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-05 · updated 2026-06-17
- Weakness: CWE-78
Description
A OS Command Injection vulnerability exists in Node.js versions <14.21.1, <16.18.1, <18.12.1, <19.0.1 due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does not properly check if an IP address is invalid before making DBS requests allowing rebinding attacks.The fix for this issue in https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-32212 was incomplete and this new CVE is to complete the fix.
Affected products
- Debian Linux: 10.0, 11.0
- Node.js: from 14.0.0 through 14.14.0; from 14.15.0 before 14.21.1; from 16.0.0 through 16.12.0; from 16.13.0 before 16.18.1; from 18.0.0 through 18.11.0; 18.12.0, 19.0.0 — fixed in 14.21.1, 16.18.1
How to fix
Upgrade to a fixed version: Node.js 14.21.1, 16.18.1. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/02/msg00038.html
- https://nodejs.org/en/blog/vulnerability/november-2022-security-releases/
- https://security.netapp.com/advisory/ntap-20230120-0004/
- https://security.netapp.com/advisory/ntap-20230427-0007/
- https://www.debian.org/security/2023/dsa-5326
- https://lists.debian.org/debian-lts-announce/2023/02/msg00038.html
- https://nodejs.org/en/blog/vulnerability/november-2022-security-releases/
- https://security.netapp.com/advisory/ntap-20230120-0004/
- https://security.netapp.com/advisory/ntap-20230427-0007/
- https://www.debian.org/security/2023/dsa-5326
Get alerted when CVE-2022-43548 or the next vulnerability affects your stack