What’s Vulnerable › Vulnerabilities

CVE-2022-43561: Persistent Cross-Site Scripting in “Save Table” Dialog in Splunk Enterprise

Description

In Splunk Enterprise versions below 8.1.12, 8.2.9, and 9.0.2, a remote user that holds the “power” Splunk role can store arbitrary scripts that can lead to persistent cross-site scripting (XSS). The vulnerability affects instances with Splunk Web enabled.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 8.1.12, 8.2.9, 9.0.2; Splunk Cloud Platform 9.0.2208. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-43561 or the next vulnerability affects your stack