What’s Vulnerable › Vulnerabilities

CVE-2022-43566: Risky command safeguards bypass via Search ID query in Analytics Workspace in Splunk Enterprise

Description

In Splunk Enterprise versions below 8.2.9, 8.1.12, and 9.0.2, an authenticated user can run risky commands using a more privileged user’s permissions to bypass SPL safeguards for risky commands https://docs.splunk.com/Documentation/SplunkCloud/latest/Security/SPLsafeguards  in the Analytics Workspace. The vulnerability requires the attacker to phish the victim by tricking them into initiating a request within their browser. The attacker cannot exploit the vulnerability at will.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 8.1.12, 8.2.9, 9.0.2; Splunk Cloud Platform 9.0.2208. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-43566 or the next vulnerability affects your stack